
Java Integrated Development 
Environments: ECLIPSE 
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Installation 
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Eclipse Installation 

■ Detailed Instructions 
http://www.3plus4software.de/eclipse/installation_e
n.html 

■ Basic Ingredients: 
■ Windows, Linux, Solaris, QNX or Mac OS/X 

operating system.  
■ 256 MB RAM or more 
■ A Java 2 runtime environment (JRE) or Java 2 

Software Development Kit (J2SDK). Eclipse needs 
version 1.3 or higher .  
 

■ Eclipse SDK version 2.1.3 (the last stable version) 

http://www.3plus4software.de/eclipse/installation_en.html
http://www.3plus4software.de/eclipse/installation_en.html
http://java.sun.com/j2se/1.3/download.html
http://java.sun.com/j2se/1.4.1/download.html
http://download.eclipse.org/downloads/index.php


200303331 4 

Eclipse Installation 

■ Extract eclipse-SDK-*-*.zip in the path that will now 
more be the %eclipse_home%. An eclipse directory will 
be created. 
– E.g. C:\eclipse 
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Eclipse Installation 

■ Eclipse is a Java program. You have to specify the 
Java path. There are two ways: 
– 1st:Specify the Java path in the PATH environment variable 
– 2nd:Copy the jre folder from the JAVA_HOME directory to the 

ECLIPSE_HOME directory 

■ Run eclipse; Click on the eclipse icon 
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Eclipse Installation 

■ Alternative. Run eclipse from a command line 
window specifying the Java path (-vm) 

■ Gives flexibility in specifying various parameters 
when starting eclipse 
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Eclipse Installation 

■ For more details on running eclipse visit this: 
http://help.eclipse.org/help21/index.jsp?topic=/org.
eclipse.platform.doc.user/tasks/running_eclipse.htm 

■ The eclipse site http://www.eclipse.org 
 
 

http://help.eclipse.org/help21/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/running_eclipse.htm
http://help.eclipse.org/help21/index.jsp?topic=/org.eclipse.platform.doc.user/tasks/running_eclipse.htm
http://www.eclipse.org/
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Workbench 
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Workbench 
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Workbench 

 
■ Editors 

– A visual component within the workbench 
– Used to edit or browse a resource 

■ Views 
– A visual component within the workbench 
– Used to navigate a hierarchy of information, open an 

editor or display properties of an active editor 
■ Perspectives 

– Groups of views an editors within the workbench 
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A simple example… perspective 

views 

editor 
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Creating resources 

■ Three alternatives 
1. File menu 
2. Navigator context menu (right-click on selected 

resource) 
3. New Wizard button 
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Creating a new project 
 
■ From the menubar, select File > New > Project… 
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Creating a new project 



200303331 15 

Creating a new project 
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Creating a new folder 
■ From the popup menu of a 

project in the navigation view, 
select New > Folder 
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Creating a new folder 
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Creating a new file 

■ From  the toolbar use the “New” 
Wizard button and select “File” 
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Creating a new file 
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Creating a new file 
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Editors 

■ Editors are tiled using tabs (if there is more than 
one file opened) 

■ The appropriate editor is used according to the type 
of file 
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Editors 
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Editors 
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Stack editors 
■ Possible both side by side and one above the other 



200303331 25 

Stack editors 
■ Possible both side by side and one above the other 
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Views 

■ Views help you work with resources in addition to 
editors 
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Views (example) 
■  The Navigator view displays the projects and other 

resources that you are working with 

Navigator 
View 
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Views (example) 
■ The bookmark view displays all bookmarks in the 

workbench along with the name of the file the 
bookmark is associated 
 

Bookmark 
view 
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Views 
■ Display views from Window > Show View menu 
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Views 

■ Experiment as much as you want with the views 
■ Rearrange the Workbench using the         

Window > Reset Perspective menu 
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Show me the files… 

■ Q: Where are my files actually stored? 
■ A: 

1. Open your file system explorer 
2. Navigate to the location where you installed eclipse 

(%ECLIPSE_HOME%). You will find a sub-directory 
called “workspace” 

3. You will find the projects, folders and files in that sub-
directory  
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Import files 

1. Drag and Drop files from the file system 
 

2. Copy and Paste files from the file system 
 

3. Use the import wizard either from the popup menu 
of the navigator or from the File menu 
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Import files 
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Import files 
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Import files 
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Import files 
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Import files 
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Link folder to file system 

■ If you do not want the contents of the folder to be 
copied in the “workspace” you have to “link” the 
folder to a position in the file system upon its 
creation 
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Link folder to file system 
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Link folder to file system 

■ Click “Advanced” 
■ Check “Link to folder in file system” 
■ Browse to find the desired folder 



200303331 41 

Link folder to file system 
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Link folder to file system 
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Link folder to file system 
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Link folder to file system 

■ If you sneak in the file system explorer you will see 
that there is no folder “StamatisLink” in the 
“workspace” folder. Any change will be 
automatically made to the resources linked in the 
file system. 



Part3 

Java Development 
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Prepare Workbench 
■ Switch to Java Perspective using                  

Window > Open Perspective > Java Menu 
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Prepare Workbench 
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Prepare Workbench 

■ Java perspective has the following views 
– Package Explorer 
– Hierarchy 
– Outline 
– Search 
– Console 
– Tasks 
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Prepare Workbench 
■ Verify JRE installation and classpath variables 
■ Select menu Window > Preferences  
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Prepare Workbench 
■ Select Java > Installed JREs 
■ Confirm that a JRE has been automatically detected. 
■ The use of an SDK rather than a JRE is 

recommended 
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Prepare Workbench 
■ Select “Workbench” 
■ Make sure “Perform build automatically on resource 

modification” is checked 
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Code Organization  

■ Projects 
■ Packages 
■ Classes 
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Create a new Java project 

■ Projects are the containers of packages 
■ All java projects are directly stored inside a project 
■ Generated CLASS files are stored along with the 

JAVA source files 
■ Two ways to create a new project 

1. From the File > New > Project menu 
2. From the “New Java Project” icon in the toolbar 
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Create a new Java project 
■ Select “Java”, then Next 
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Create a new Java project 
■ Choose whether you will “import” content in the project. 

In this case the content is NOT copied in the workspace 
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Create a new Java project 

■ Add any external jars necessary to run your code  
(if any) 

■ Click “Finish” 
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Create a new Java project 
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Create a new Java package 

■ Choose the project that will contain the package 
from the Package Explorer 

■ Three ways to create the new package 
1. From the pop-up menu (right-click on the project) 

select New > Package 
2. From the “File” menu select New > Package 
3. From the toolbar using the “New Package” icon   
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Create a new Java package 

■ Give a name to the package 
■ Click “Finish” 
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Create a new Java package 
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Create a new Java Class 

■ There are various ways to create a new Java Class 
–  Select the package where the new class will reside 
1. Use “New Class” icon in the workbench toolbar 
2. From the package’s pop-up menu (right-click) choose 

New > Class 
3. From the toolbar select the “New” icon’s drop-down 

and then select “Class” 
4. From the toolbar select the “New” icon and then “Java” 

in the left pane and “Class” in the right pane 
5. Select File > New > Class menu 
 

■ You can always type a new class in an existing Java 
file from the Package Explorer 
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Create a new Java Class 
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Create a new Java Class 

■ Select a class name 
■ Select possible 

superclass 
■ Select possible 

implementing interfaces 
■ e.t.c 
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Create a new Java Class 
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Java editor features 
■ Import assistance 
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Java editor features 

■ Method Completion (automatically or using Ctrl+Space) 
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Java editor features 
■ Hovering over identifier shows Javadoc spec 
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Java editor features 

■ On-the-fly spell check 

Hover over this 
to see mistake 
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Java editor features 

■ Quick Fix 

Double click 
here to get 
suggestions 
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Java editor features 

■ Code templates (Ctrl+Space) 
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Java editor features 

■ Argument hints 
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Java editor features 
■ JavaDoc Assist 



200303331 73 

Class Hierarchies 



200303331 74 

Class Hierarchies 
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Class Hierarchies 



200303331 76 

Class Hierarchies 
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Class Hierarchies 
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Class Hierarchies 
■ Select a type and from its pop-up select “Open Type 

Hierarchy” 
■ The Hierarchy View will appear 
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Class Hierarchies 
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Search for Java Elements 
■ Declarations or References 
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Search for Java Elements 
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Search for Java Elements 
■ Select a type or method 
■ From its pop-up select Search > References > Workspace 
■ You will retrieve all it’s references in the Search View  
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Search for Java Elements 

Search 
View 
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Run Java Programs 

■ Build is performed automatically upon resource 
modification 

■ If you want to do it explicitly select menu 
Project>Rebuild project 

■ Two ways to run a project: 
– Select menu Run > Run As > Java Application  
– Click on the “Run” icon in the toolbar 
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Run Java Programs 
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Run Java Programs 
■ The Console View shows up with the output! 

Console 
View 
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UML 



200303331 88 

Eclipse UML Installation 

■ Exit eclipse 
■ Download EMF (Eclipse Modeling Framework) zip file 

from http://www.omondo.com/download/free/index.jsp 
■ Unzip EMF zip in %ECLIPSE_HOME% directory 
■ Re-start eclipse 
■ Exit eclipse 

http://www.omondo.com/download/free/index.jsp
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Download this 
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Eclipse UML Installation 
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Eclipse UML Installation 

■ Download Eclipse UML zip file from 
http://www.omondo.com/download/free/index.jsp 

■ Unzip Eclipse UML zip in %ECLIPSE_HOME% 
directory 

■ Re-start eclipse 
■ That’s it! 

 
 

■ More details in: 
– http://www.omondo.com/faq/free/index.jsp#emfzipi 
– http://www.lifl.fr/~offroy/eclipse_HTML/internal/instal

lation/Eclipse_Java_&_UML_install.html 
 

 

http://www.omondo.com/download/free/index.jsp
http://www.omondo.com/faq/free/index.jsp
http://www.lifl.fr/~offroy/eclipse_HTML/internal/installation/Eclipse_Java_&_UML_install.html
http://www.lifl.fr/~offroy/eclipse_HTML/internal/installation/Eclipse_Java_&_UML_install.html
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Download This 
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Eclipse UML Installation 
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Create your first class diagram 

■ Select a package 
■ From it context menu (right-click) select 

New>Other>UML->UML Class Diagram 
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Create your first class diagram 
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Create your first class diagram 
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Create your first class diagram 

■ Choose the kind of 
relationship you want to be 
depicted 
– Association 
– Inheritance 
– Dependency  



200303331 98 

Create your first class diagram 

■ Choose the classes that will 
participate in the diagram 
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Create your first class diagram 
■ Here is it! 
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Prepare Workbench for UML design 
■ Select menu Window > Preferences 
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Prepare Workbench for UML design 
■ We will create a src and a 

bin output for the UML 
project 
 

■ Select Java > New Projects 
 

■ Click on “Folders” checkbox 
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Prepare Workbench for UML design 

■ Select “UML” 
 

■ Click on checkbox 
“with text” 



200303331 103 

Prepare Workbench for UML design 

■ Select                  
UML>Class Diagrams>Class 
 

■ In attributes pane check 
boxes “Public”, ”Private”, 
“Protected” and “Package”  
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Eclipse UML Class Diagrams 
■ Select Java Perspective 
■ Create a new Java project named “Company” 

 
The src folder is 
created automatically 
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Eclipse UML Class Diagrams 
■ Select src folder 
■ From it’s pop-up menu select UML>Class diagram editor 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 
■ Create a New Package. 
■ Select “new package” in the toolbar and click on the 

diagram. 
■ Name it “model” 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 
■ Create a new Class Diagram inside the “model” Package  
■ Right-click on model then Open>model.ucd (ucd is the 

class diagram extension). 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 
■ Create a New class 
■ Select New class in the toolbar and click on the diagram. 
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Eclipse UML Class Diagrams 
■ Enter the name of the New Java Class and check 
■ Enter Person and click on the Finish button. 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 
■ We are going to add two new Attributes. 
■ Click on Person>New>Attribute. 
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Eclipse UML Class Diagrams 
■ Enter Attributes properties: "age: int" and "name: 

String" 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 
■ Create a New class named Employee. 
■ We would like to add inheritance from Employee to 

Person. 
■ Select Generalization in the Toolbar 
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Eclipse UML Class Diagrams 
■ Drag the Inheritance from Employee to Person. 
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Eclipse UML Class Diagrams 
■ Add "salary: float" attribute to Employee 
■ Create a New class named Company. 
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Eclipse UML Class Diagrams 

■ We want to create a new 
Association between Company 
and Employee. 
 

■ Select Association in the 
Toolbar then drag from 
Company to Employee. 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 
■ It is possible to add a name to the Label, but we will 

not in this example. 
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Eclipse UML Class Diagrams 
■ Select the “1st Association End” tab 
■ Set multiplicity to 1 
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Eclipse UML Class Diagrams 
■ Select the “2nd Association End” tab 
■ Set name “employees” 
■ Set multiplicity “0..*” 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 
■ Click on Company and create two new Attributes: 

"name: String" and "activity: String" 
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Eclipse UML Class Diagrams 
■ Create a New class named Project 
■ Add attribute “name:String: to class Project 
■ Add an association between Company and Project. 
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Eclipse UML Class Diagrams 

■ In association properties 
– Label: leave blank 
– 1st associations end: 

• Name: company 
• Multiplicity:1 

– 2nd associations end: 
• Name: project 
• Multiplicity:0..1 
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Eclipse UML Class Diagrams 
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Eclipse UML Class Diagrams 

■ Add an Association between Employee and Project 
■ Select Association and drag from Employee to 

Project 
■ In the properties menu:  

– Label: leave blank 
– 1st Association End: Name: leader, Dimension 0, 

Multiplicity 0..1 
– 2nd Association End: Name: Project,  Dimension 0, 

Multiplicity 0..1 
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Eclipse UML Class Diagrams 
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Show code 
■ Select a Class 
■ From the pop-up menu select “Source editor” 
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Show code 
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The end 

■ Experiment!!! 
■ Eclipse Tutorials: 

– http://www.eclipse.org/ 
– http://www.3plus4software.de/eclipse/index_en.html 
– http://www.omondo.com/ 
– http://www.tutorial-

omondo.com/jdo/classdiagram.html 
 

http://www.eclipse.org/
http://www.3plus4software.de/eclipse/index_en.html
http://www.omondo.com/
http://www.tutorial-omondo.com/jdo/classdiagram.html
http://www.tutorial-omondo.com/jdo/classdiagram.html
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