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Vivado Installation



Applications Products Developer Zone

- Vivado HL System Edition
- Documentation Navigator (Standalone)

The Web Installer will accept your login credentials and allow
you to select the edition, device families and tool components
(SDK or DocMav). It will then automatically download only your
selection and install it on your local machine.

Mote: Use the Web Installers to install Vivado HL WebPACK and
cut your download time by up to 2/3 and download size by up
to 6GE!

For more information, please watch the Installation Overview
Video.

Please be aware that with the release of version 2016.2,
DVDs and any other forms of downloadable physical
shipment will no longer be available for ordering and will
only be available for download at Xilinx.com.

X Vivado HLx 2017.1: WebPACK 2pd Editions - Windows Self
Extracting Web Installer (EXE - 51.5F MB)
MD5 SUM Value: df4c2611b3 8c8f184bf7eeshbbba

2. Vivado HLx 2017.1: WebPACK and Editions - Linux Self
Extracting Web Installer (BIN - 85.23 MB)
MD5 SUM Value: 42fd14f5472de77354ba1f847c00eec?

& Vivado HLx 2017.1: All OS installer Single-File Download
(TAR/GZIP - 20.21 GB)
MD5 SUM Value: ee351905f061e19751999e69b41f4b22

Navigate to the Xilinx Downloads page,
and Download Vivado 2017.1 WebPack
edition.

We are going to use version 2017.1,
but any other Vivado version will do.

Use the Web Installer, in order to minimize
The required download space.
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€ vivado 2017.1 Installer - Select Edition to Install —

Select Edition to Install Xl LI NX

Select an edition to continue installation. You will be able to customize the contentin the next page. ALL PROGRAMMABLE.

(® Vivado HL WebPACK
Vivado HL WebPACK is the no cost, device limited version of Vivado HL Design Edition.

(O Vivado HL Design Edition
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* In the window that appears, make sure to select
the WebPACK edition,

Next = Cancel

Copyright ® 1386-2017 Xilinx, Inc. All rights reserved.




€ vivado 2017.1 Installer - Vivado HL WebPACK O >

Vivado HL WebPACK

XILINX

Customize your installation by (de)selecting items in the tree below. Moving cursor over selections below provide additional information. AlLL PROGRAMMABLE.
Vivado HL WebPACK is the no cost, device limited version of Vivado HL Design Edition.

=% % Design Tools
| B [E] Vivado Design Suite
i Vivado
System Generator for DSP
Vivado High Level Synthesis
: |:| Software Development Kit (SDK)
3 DocNav
* Devices
- [®m] Production Devices
s =~ [@] socCs
f — Zyng-7000 (limited support)
[0l zynqUltraScale+ MPSoC (limited support)
7 Series (limited support)
- Artix-7
Kintex-7
Spartan-7
Virtex-7
|:] UltraScale (limited support)
Kintex UltraScale
: Virtex UltraScale
=- |:| UltraScale+ (limited support)
Kintex UltraScale +
g Virtex UltraScale +
G- Engineering Sample Devices
./ Installation Options
Install Cable Drivers
Enable WwebTalk for Vivado to send usage statistics to Xilinx (Always enabled for WebPACK license)
Install WinPCap for Ethernet Hardware Co-simulation
Launch configuration manager to assocdate System Generator for DSP with MATLAB
Enable WebTalk for SDK to send usage statistics to Xilinx

Download Size: 3.28 GB Reset to Defaults
Disk Space Required: 13.55 GB

Copyright ® 1586-2017 Xilinx, Inc. All rights reserved. Cancel




Creating a new Project



¢ Vivado 2017.1 —

File  Flow Tools Window Help Q'f‘?’»w;* Access
VIVADO & XILINX
HLx Editions o AULRR OGRAMMABLE.

Qu ick Start Recent Projects
: project_2
Create Project > C/Users/Sertralvivado_projects/proj
Open Project > i
Open Example Project > C:/Users/Settra/vivado_projects/project_1

IENS

Manage IP >
Open Hardware Manager >

Xilinx Tcl Store >

leaiping Cenier

Documentation and Tutorials >
Quick Take Videos >

Release Notes Guide >

* When you run Vivado, this is the window that appears. Select “create project”



File Flow Tools Window  Help Q- Quick Access

VIVADO!

HLx Editions

¢ New Project

Quick Start

Create Project >
Open Project >

Project Name

Enter a name for your project and specify a directory where the project data files will be stored. '

Open Example Project > Project name: project_name

Project location: | C:/Users/userivivado_projects |E]

V| Create project subdirectory

Tasks

Manage IP >

Project will be created at: C:/Users/useriivado_projects/project_name

Open Hardware Manager >

Xilinx Tcl Store >

Eesrning Center

Documentation and Tutorials >

Quick Take Videos >

Release Notes Guide >




File

Flow Tools Window Help Q- Quick Ac

w

VIVADO!

HLx Editions

Quick Start

Create Project >
Open Project >
Open Example Project >

Tasks

Manage IP >
Open Hardware Manager >

Xilinx Tcl Store >

Learning Center

Documentation and Tutorials >

Quick Take Videos >

Release Notes Guide >

’

New Project

Project Type

Specify the type of project to create.

RTL Project
You will be able to add sources, create block designs in IP Integrator, generate IP, run RTL analysis, synthesis,
implementation, design planning and analysis.

Do not specify sources at this time

Post-synthesis Project: You will be able to add sources, view device resources, run design analysis, planning and
implementation.

1/O Planning Project
Do not specify design sources. You will be able to view part/package resources.

Imported Project
Create a Vivado project from a Synplify, XST or ISE Project File.

Example Project
Create a new Vivado project from a predefined template.

Cancel
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File

uick Access

Flow Tools Window Help Q- Quic

VIVADO’

HLx Editions

Quick Start

Create Project >
Open Project >
Open Example Project >

Tasks

Manage IP >
Open Hardware Manager >

Xilinx Tcl Store >

Learning Center

Documentation and Tutorials >
Quick Take Videos >

Release Notes Guide >

¢ New Project

Add Sources

Specify HDL, netlist, Block Design, and IP files, or directories containing those files, to add to your project. Create a new source '
file on disk and add it to your project. You can also add and create sources later.

o+

4

Use Add Files, Add Directories or Create File buttons below

Add Files | I Add Directories I | Create File

Targetlanguage: @ Verilog w Simulator language: = Mixed o

If you have your code ready, you can add it by selecting “add files”.
* You can always add more files later




#% Vivado 2017.2

File Flow Tools Window Help Q- Quick Access

VIVADO'

HLx Editions

¢ New Project X

Add Sources

C Proi 3 Specify HDL, netlist, Block Design, and IP files, or directories containing those files, to add to your project. Create a new source ‘
Create Project > file on disk and add it to your project. You can also add and create sources later.

Open Project >
Open Example Project >

+, - 'l
Index Name Library HDL Source For Location
@ 1 M_Ov  xil_defaulib | Simulation only | ~ | cuusersisetiramesktopGAlti_folder
T k @ 2 i_1v xil_defaultlib Synthesis & Simulation v C:/Users/Settra/Desktop/VGA/rt_folder
a S S @ 3 ri_top.v  xil_defaultlio Synthesis & Simulation ~  C:/Users/Settra/Desktop/VGA/rt_folder

Manage IP >

Open Hardware Manager >

Xilinx Tcl Store >

I—e a r n I n g Ce nte r Add Files ‘ | Add Directories ‘ I Create File

Documentation and Tutorials > Scan and add RTL include files into project

Quick Take Videos > Copy sources into project

Release Notes Guide >
Targetlanguage: Verilog v Simulator language: = Mixed v

®

* Files used for simulation should be set as “simulation only” in the drop down menu. All others as “synthesis &

simulation”

* Selecting “Copy sources into project” will copy the source files, into the project subdirectory. Warning: Any
changes made to them, when opening the files from Vivado, will happen to the copied sources, and not in the
original location.



File  Flow Tools Window Help Q- Quick Access

VIVADO!

HLx Editions

¢ New Project

Quick Start

Create Project >
Open Project >

Add Constraints (optional)
Specify or create constraint files for physical and timing constraints. ‘

Open Example Project >

Tasks

Manage IP >
Open Hardware Manager >

Xilinx Tcl Store > Use Add Files or Create File buttons below

Learning Center

Documentation and Tutorials >
Quick Take Videos >

Add Files l | Create File

Release Notes Guide >




File Flow Tools Window Help = - QuickAccess

VIVADO/

HLx Editions

Quick Start

Create Project >
Open Project >
Open Example Project >

Tasks

Manage IP >
Open Hardware Manager >

Xilinx Tcl Store >

Learning Center

Documentation and Tutorials >
Quick Take Videos >

Release Notes Guide >

New Project

Default Part

Choose a default Xilinx part or board for your project. This can be changed later.

Select {8 Parts | Bl Boards

v Filter/ Preview

Vendor: em.avnet.com v el et L -
Display Name: I ZedBoard Zyng Eval... vl = .
Board Rev: Latest v i
Search: .- .
Display Name Vendor Board Rev  Part
@ ZedBoard Zynq Evaluation and DevelopmentKit em.avnetcom d {8} xc7z020clg484-1

No Board Connectors

®

Next Page

/0 Pin Count  File\

13

Cancel




File  Edit Flow Tools

=, ~ B X " B X » ¥ = Default Layout v
Flow Navigator = 9 PROJECT MANAGER - project_name ? X 4
v PROJECT MANAGER 2

Sources ?2 008X Project Summary 200X
£ Settings A
Q| = ||+ o
Add Sources Settings  Edit
1 g, s v = Design Sources (1)
anguage Templates . ; !
s y v @& adder_top (adder_topv) (4) Project name: project_name
4 IP Catalog > @ FA_0:full_adder (full_adderv)(2) Project location: C:Users/Settraivivado_projects/project_name
> @ FA_1:full_adder (full_adderv) (2) Product family: Zyng-7000
Vv P INTEGRATOR > @ FA_2:full_adder (full_adderv) (2) Project part: ZedBoard Zynqg Evaluation and Development Kit (xc7z020cig484-1)
Create Block Design > @ FA_3:full_adder (full_adderv) (2) Top module name: adder_top
™. Constraints - i
Open Block Design Target language: Verilog
constrs_1 Simulator language:  Mixed
Generate Block Design v Simulation Sources (1)
g sim_1(1)
Vv SIMULATION v @& tb(adder_tov) (1) Board Part
" i v@ : dder_top.v) (4)
Run Simulation WL UIE addar dp (ddder T D) Display name: ZedBoard Zynq Evaluation and Development Kit
> @ FA_O:full_adder (full_adderv) (2)
S M s . Board part name: em.avnet.com:zed:part0:1.3
[ 2 V) (2) ——
v RTLANALYSIS $ R L O e Connectors:
- 5 > @ FA_2:full_adder (full_adderv)(2) .
> en Elaborated Design i - IXilinx/Vi
p g > @ FA_3:full_adder (full_adderv) (2) Repository path: Cu/XilinwVivado/2017.2/data/boards/board_files
URL: http:/iwww.zedboard.org
v SYNTHESIS Board overview: ZedBoard Zynq Evaluation and Development Kit et e
P Run Synthesis Hierarchy  Libraries  Compile Order
> Open Synthesized Design
Source File Properties ? _0OGX D B
v IMPLEMENTATION @ adder_tov - o O Status: Not started Status: Not started
P Run Implementation Z Messages:  No efrors or warnings Messages: No errors or warnings
> OpenImplemented Design General Properties Part: xc72020clg484-1 Part: xc7z020clg484-1
7 S o 1 < |

Vv PROGRAM AND DEBUG

ii Generate Bitstream

> Open Hardware Manager

Layout View Help Q- Quick Access

Ready

TclConsole X Messages Log Reporis Design Runs

Q = 2 Il B B o




* Flow Navigator. From here you can :

e Addanew P

Elaborate the design

Synthesize and Implement the design

Open Hardware manager, to download the bitstream in the FPGA.

Elaborate design. Gives the main idea, of the schematic, that the tool (Vivado) understands by
your code.

* Helps supervise non-trivial connections (i.e generated by a generate block)

* Especially usefull when trying to solve “multi-driven” error issues

Synthesize design. Generates the LUT-level schematic of the design. From here you can check
timing , utilization, and critical paths.

* Implement design. Implements the synthesized design, to the FPGA device that we are using.



FEile Edit Flow Tools

~3 E
Flow Navigator 3
v PROJECT MANAGER
£ Settings

Add Sources
Language Templates

¥ |P Catalog

IP INTEGRATOR

Create Block Design

SIMULATION

Run Simulation

RTL ANALYSIS
> Open Elaborated Design

SYNTHESIS
P Run Synthesis

> Open Synthesized Design

IMPLEMENTATION

P Run Implementation

> Openimplemented Design

PROGRAM AND DEBUG

¥ Generate Bitstream

> Open Hardware Manager

X b, W

General Properiies

Layout View Help Juick Access

& 2 ¥

PROJECT MANAGER - project_name
Sources ? 008X
Q= e+ o

v - Design Sources (1
v @ adder_top (adder_topv) (4
> @@ FA_O:full_adder (full_adderv)(2
> @ FA_1:full_adder (full_adderv) (2
> @ FA_2:full_adder (full_adderv) (2

[}
> @ FA_3:full_adder (full_adderyv) (2
v Constraints °
constrs_1
v Simulation Sources (1
R sim_1(1
°

v @dde tb(adder_tbv) (1)
v @@ UUT: adder_top (adder_top.v) (4
> @ FA_O:full_adder (ful
> @@ FA_1:full_adder
> @@ FA_2:full_adder (full
> @ FA_3:full_adder (full_adderv)(2

(full

Hierarchy Libraries Compile Order

Source File Properties 2 _ 00 X

¥ adder_tbv G o

-

Tcl Console X Messages Log Reports Design Runs

Q == 2 I B B o

From the sources window, we are going to use only the
“Hierarchy” tab. It consists of:

Design sources: the actual code of our module.

Simulation sources: Code only used for the simulation of our module
i.e testbench.

Constraints: .xdc files used for synthesis/implementation. These files
contain information on how the I/O of our module, connects to
actual 1/0 of the FPGA. It also has information about the clock, used
by the tool to synthesize the design accordingly.



File Edit Flow Tools
=

A

e
W

Flow Navigator
v PROJECT MANAGER
£F Settings
Add Sources
Language Templates

ZF IP Catalog

Vv |IP INTEGRATOR
Create Block Design
Open Block Design

Generate Block Design

Vv SIMULATION

Run Simulation

v RTL ANALYSIS
v Open Elaborated Design

Report Methodology
Report DRC
Report Noise

*4 Schematic

Vv SYNTHESIS
» Run Synthesis

> Open Synthesized Design

Vv IMPLEMENTATION

» RunImplementation

> Openlimplemented Design

Vv PROGRAM AND DEBUG

i Generate Bitstream

> Open Hardware Manager

Layout  View

® > B oH

B & X

Help Q- Quick Access

ELABORATED DESIGN - xc7z020clg484-1 (active)

‘Sources ‘ |CeIlPropenies l

‘ Netlist

Project Summary x  Schematic X adder_topv X | adder_tby X
- = @ Q| ¢ & O C  9cCells 13l0Ports 29 Nets
Elaborated design example, of a 4-bit adder
FA_O
cany_in camry_out
i X[3:0] D 0 in_x sum_out 0
i y[3:0] S
full_adder
FA_1
camy_in carry_out
1 in_x sum_out 1
in_y
full_adder
FA 2
carry_in carry_out
2 in_x sum_out 2 FA_3
in_y ,.B =
full_adder cany_in —_> o_overflow
ul_half_adder ™ o _out3:0]
.
3 in_x in_x out_carry jo _carry_out i
z = o] carry_out
3 iny iny odt_Sm u2_half_adder 1
half_adder » i TL_OR
in_x 1o _out_carry |
in_y I1J O Ol cary sum_out 3
‘_R'T{_AND
1o out_sum_i
j o] out_sum
TL_XOR
half_adder
full_adder
Tcl Console | Messages Log Reports De5|gnRuns]



Simulation



* Click “Run Simulation” -> “Run behavioral Simulation”
e Usually, if errors occur, you will get messages like that:

TclConsole | Messages

QT ¢ v 8 0@

v @ Vivado Commands (2 errors)

X Log Reports

v @ launch_simulation (2 errors)

7 @ Error (2) @ info (1) []® Status (3) Show All

Design Runs

@ [USF-XSim-62] 'compile’ step failed with error(s). Please check the Tcl console output or 'C:/Users/Settravivado_projects/project_name/project_name.sim/sim_1/behavixviog.log’ file for more information.
@ [vivado 12-4473] Detected error while running simulation. Please correct the issue and retry this operation.

?

- O [

If that’s the case, more details about the errors can be found in the “Tcl console” tab

ERRCR: [VRFC 10-91]
ERROR: [VRFC 10-91]
ERROR: [VRFC 10-91]
ERROR: [VRFC 10-91]

Tcl Console X Messages Log Reports

Q = s Il B B @

X is not declared
¥ is not declared
X is not declared
¥y is not declared

Design Runs

[C:/Users/Settra/Desktop/rtl/adder_top.v:40]
[C:/Users/Settra/Desktop/rtl/adder_top.v:4l]
[C:/Users/Settra/Desktop/rtl/adder_top.v:49]
[C:/Users/Settra/Desktop/rtl/adder_ top.v:50]




vV

Layout View Run

Sim controls

LI < BD 10 us v % (&
SIMULATION - Behavioral Simulation - Functional - ST

Scope Objects
Q=S Q &
Name Design Unit Block Type Name Value DataT..”
v @tb to Verilog M... @ clk 0 Logic

> S uuT adder_top Verilog M... > 4% count[3:0] 2 Array

& glbl glbl Verilog M... > 9§ adder_outl... 3 Array

@ overflow 0 Logic

Untitled 1*

Q H & Q| X | |I4]) +

Name
1% clk
 Mcount30] |
"™ adder_out[3:0]

¥ overflow

If all went well, you should get a screen like that

Ready

Default Layout




e Sim controls: reset simulation, or move forward in time. Or
relaunch simulation, if source files have changed.

* Scope: All the instantiated modules found in your Verilog code.

* Objects: all the “variables” , of the module selected in the “scope”
window. Wires, registers, 10. From here you can drag and drop
them in the simulation window in order to monitor them.



A
Name
% clk

> %4 count[3:0]

> 9 adder_out]...

@ overflow

umary.

10:00:17 ; elapsed = 00:00:16 .

Value

o W N

0 Errors encountered.

Logic
Array
Array

Logic

N

>v-

Memory

Name

Iy clk

™ count[3:0]

% adder_out{3:0]

1 overflow

(MB): peak = 1193.359

)

2 | ] 4}

Value

Go To Source Code
Show in Object Window
Report Drivers

Force Constant...

Force Clock...

Remove Force

Cut
Copy

Delete
Find...

Find Value...
Select All
Expand

Rename
Name
Waveform Style

Signal Color

Radix

Reverse Bit Order

. New Group

New Divider

% New Virtual Bus

M O MM

By right clicking on a signal you can:

Force a constant value: Force the signal to act
as having a specific value, usually to see how
other signals will react. Be sure to do it AFTER
the simulation has been reset.

Radix: Choose if the values are represented in
hex/dec etc.

Signal Color: change the waveform color of the
signal. Useful for grouping signals. Just avoid
orange, blue and red since simulator already
uses those.

New divider: add a divider line between
signals, for easier grouping.

New virtual Bus: usually useful for splitting
larger busses, into smaller ones, with
meaningful values



